Readerware Newsletter - February 2018

Readerware Newsletter

 

 

Welcome to the Readerware® Newsletter

 

Readerware 3.60 Released

Welcome to the Readerware Newsletter There have actually been a couple of releases since the last Readerware Newsletter so we have some catching up to do.

Readerware 3.60 is now available for Windows, Mac and Linux.

Recent upgrades include:

There have been a couple of changes to Readerware Client/Server Edition to support larger databases and to help you maintain your databases.



You can now choose the font when printing barcode and spine labels.



Fixed a problem opening a Readerware database that had not been closed cleanly. You could receive a database does not exist error, now the database will open as usual.



Improved export logging.



The UIEE export did not always include the price field, this has now been fixed.



The Borrower ID column was empty on a loan search, this has now been corrected. You can now also export the Borrower ID column.

A full list of the changes included in Readerware 3.60 is available in the release notes. You can also access the release notes from Readerware itself, select the Help->Release notes menu item.

We recommend that everyone upgrade to Readerware 3.60.

Download Readerware 3.60

 


 

The Readerware website

Readerware Website The Readerware website is now a secure site. This means that all information sent to and from our website is encrypted.

Our ordering pages have always included encryption of course but now we have extended encryption to all the pages on our site. Nobody can listen in to your communications with the Readerware website.

You don't have to make any changes in your browsing habits or update any bookmarks, you will automatically be redirected to our secure pages.

Several browser makers have announced that they will soon begin flagging sites that do not use encryption as “Not Secure”. The Readerware website is ready.

If you run into any problems with the new site, please contact support@readerware.com

Readerware Client/Server Edition changes

Readerware Client/Server Edition There are two changes in Readerware 3.60 that effect Client/Server Edition users.

The first change affects your database. To minimize disk space your database should be compacted. This keeps the database small and efficient. Normally Readerware takes care of this automatically, it will compact your database at regular intervals to keep it in optimum shape. However with Readerware Client/Server Edition, Readerware cannot compress the database on the fly as it will affect your users. This especially becomes a problem if you keep your server running for long periods of time and are adding a lot of new items to your database.

The RWServer Config utility now has a new Database menu. You can select the appropriate database from this menu to launch the Compact Database wizard. No users should be connected to the server while the database is being compacted. Any new connection attempts will be rejected with a message that the server is in maintenance mode and the user is advised to try again later.

On the first page of the wizard the database name is displayed with the current size of the database. Click the Next button to start compacting your database. This can take some time depending on the size of the database and how long it has been since the database was last compacted. When the operation finishes, click Next to display the results.

On the results page we display the size before and after compaction. You can use these to determine how often you need to compact your database. We also display the current status of the Readerware Server. Once you close the wizard the server is back to normal and users can reconnect.

The second change we made affects the size of your database. A standard Readerware database can hold up to 2GB of data. This is way more than most users will ever need. However one user did run into this limit and so you can now increase the size of your database to 8GB. This is done using backup and restore. You first backup your database and then restore it. On the restore there is now a new option to create a maximum size database. Check this option and after the restore completes your database can now hold up to 8GB of data.

We don't recommend that you increase the size of your database unless you start running into the size limit.

Printing labels

Printing labels A number of users asked us to add font selection when printing barcode and spine labels. The default fonts have not changed so if you print any labels and leave the font selection unchanged, your new labels will match your existing labels.

You can now select the font, the style and the point size for your labels. If you increase the point size a lot the text may overflow the label, so you want to keep the size about the same. On barcode labels, the font selection will only affect the text you added to the label. The data printed as part of the barcode will not change. When printing spine labels the font selection will be applied to the number and the text added to the label.

Several users asked if there was a way to print spine labels with just a line of text, no Dewey Decimal Number or Call Number. We have added a third source value when printing spine labels. If you select None, then only your added text line will print. This also means that a label for every item selected will print. When printing Dewey Decimal Number or Call Number spine labels, an item that does not have anything in the selected field, will be skipped. When you select a source of None, every item selected will print.

Transferring Readerware and your database to a new machine

Transferring Readerware This is one of the questions we get asked all of the time. You have a new computer and you want to transfer Readerware and your database to your new machine.

Firstly, there is no charge for switching machines or operating systems. You can always transfer Readerware to a new machine even if it is running a different operating system.

The best way to transfer your database to your new machine is to use backup and restore. Start on your old machine and backup your database, select the File->Backup database menu item. A Readerware backup file is a full backup, it contains all your data and your Readerware preferences. When transferring Readerware to your new machine you want not only your full database, but you also want all your preferences which includes reports, views, mobile, export settings etc.

To transfer your backup file to a new machine, you can copy it to a thumb or external drive, burn it to a CD, upload it to the cloud or simply transfer it over your home network.

On your new machine the first thing to do is to install Readerware. Some users have tried using third party clone applications to transfer Readerware itself. This typically doesn't work well, Readerware needs to be installed on your new system. Go to our website and download the latest version of Readerware compatible with your new machine.

When you run Readerware on your new machine, you will notice that it is unregistered. Before you go searching your files for your Readerware registration codes, the good news is that you won't need them if you follow these instructions. Click Continue to enter Readerware in evaluation mode and the Database Chooser is displayed. You can create a new database, open an existing database or restore a database. We want to Restore a Database.

When the Restore Wizard opens, click on the Browse button. The standard file selection dialog will be displayed and you can select the Readerware backup file you transferred from your old machine. If you transferred your backup file using a thumb drive or CD, we recommend copying it to your new hard drive before restoring. Click Next.

Next the Restore Options page is displayed. This is the important step, you can restore your database, your preferences or both. When transferring Readerware to a new machine you want to restore both. So make sure the Restore Readerware database and Restore Readerware preferences options are checked. Click Next.

The Database Selection page of the wizard is displayed. You don't have to enter anything on this page. by default Readerware will restore your database to your Documents->Readerware folder with the same name that it had on your old machine. However if you want to change the name of the database or restore it to a different location, click on the Browse button to make the change.

The Verification page of the wizard is displayed. This is your chance to verify your selections, make sure that both restore options are set and the new database name and location is correct. Click Next to begin the restore. This may take a little while depending on the size of your database. When done click Next and Finish the wizard.

Readerware opens the new database and displays it as normal. Note that the window looks that same as it did on your old machine, the same view is displayed with your choice of columns etc. Select the Help->About Readerware menu item, notice that Readerware is registered to you. Your registration information was included in the preferences that came from your old machine.

That is it, you are ready to go.

 

 

Subscription information

You are receiving this newsletter because you joined the Readerware Newsletter mailing list.

To unsubscribe from this newsletter or change your subscription click here.

You can also unsubscribe from this newsletter by replying to this e-mail with REMOVE in the subject line.



This message was sent by Readerware Corporation.

 

 

 

Readerware Corporation


PO Box 1059


Clearlake Oaks CA  95423

 

 

 

 

Top of Page

Copyright © 2018 Readerware Corporation

Readerware is a registered trademark of The Readerware Corporation.

News

Readerware 4.02 and Readerware 3.64 Released

Readerware 4.02 and Readerware 3.64 have been released for Windows macOS and Linux. Read more...

Read More News

Readerware Newsletter - November 2018

Readerware 4.01 has been released, a new Windows installer and Readerware on a Chromebook. Read more...

Newsletter Archive