Readerware Newsletter - December 2019

Readerware Newsletter
 

 

Welcome to the Readerware® Newsletter

 

Readerware 4.17 released

Welcome to the Readerware Newsletter Readerware 4.17 has been released. It includes new features and general maintenance.

This newsletter covers changes made in Readerware 4.17. It also includes how to articles for both Readerware 4 and Readerware 3 users.

A full list of the recent changes in Readerware is available in the release notes.

You can also access the release notes from Readerware itself, select the Help->Release notes menu item.

This upgrade is recommended for all Readerware 4 users. To upgrade to Readerware 4.17 start Readerware and select the Help->Check for updates menu item. You can also download Readerware 4.17 from the website.

 

 

Download Readerware 4.17

Important note for Windows users: We have added new faster servers to handle downloads. We recommend with Readerware 4.17 only, that you do not use the Windows upgrade installer. Because of the server changes the download might be slow or fail. Instead we recommend that you download the Windows Web Installer by clicking on the above link. You can also use the check for updates function in the program as described above. Instead of clicking on the Download Now button, click on the Go to Website button. Again this is just for this release, the Readerware 4.17 upgrade will use the new servers so you can use the upgrade installer for the next release.

 

 

Sorry about the last release

An apology Earlier this week we released Readerware 4.16 and started sending out the newsletter. It soon became apparent that there were serious issues with Readerware 4.16 and we pulled it from the website and returned to Readerware 4.14. We do apologize for the problems caused.

We also stopped the newsletter, some of you received it, but most didn't.

Obviously some of you got caught up in this, but hopefully most of you never knew there was a new release. We pulled it from the website and canceled the newsletter, as soon as we became aware of the issues.

So what happened? We upgraded to a new version of the Java runtime and there were issues with it. We have now switched back to the same runtime we used in Readerware 4.14. That seems to have solved the issues.

Why didn't we catch the problems here prior to release? The first problem we heard about was from Mac users. The new release would simply not install. Apple's Gatekeeper said the application was damaged. How could that be? Our downloads were signed by Apple and notarized by Apple, how could they be bad? We built the new version on a Mac, submitted it to Apple for notarization and then installed and tested it, everything went fine.

When Mac users started reporting they could not install Readerware 4.16, we downloaded it here and had the same problem. Gatekeeper said the application was damaged. That really wasn't true, the first thing we did was check the downloaded file with the master, and it was an exact copy. Why could we install it locally from our hard drive but not after it was downloaded from the web? It turns out that Apple's Gatekeeper does not look at local applications, but when you launch a downloaded application, Gatekeeper checks it first.

This problem was embarrassing to say the least. The programs just wouldn't install on a Mac. We have changed our release procedure. Rather than install the new version from a local copy of the file, we now send it on a round trip to a staging area on the Readerware website. We download it, install it, and test it. So this will not happen again.

Then we started hearing from some Windows users who installed the new version and Readerware displayed a garbled screen st startup. This was not a universal problem, like the Mac problem, it only affected some users. We tried Readerware on all our Windows machines here and could not reproduce the problem. Some users sent us screenshots so we could see what the issue was. We were convinced that this was also caused by the runtime change. But as we could not reproduce the problem here, we didn't know for sure that it was fixed. Fortunately some of the affected users volunteered to test the new version and reported everything was working normally. We really appreciate their help with this problem.

So an embarrassing release, we have had issues before but never this bad. We do apologize to everyone for the inconvenience caused, and as mentioned, we have changed our testing procedures to ensure nothing like this happens again.

Now back to our regular newsletter...

Views in Readerware

Views in Readerware We made a much requested change in how we handle views in this release of Readerware, so this seemed like a good time to go over views in general. This should be useful for both Readerware 4 and Readerware 3 users.

There are several different types of views in Readerware, including table, tree and thumbnail views. By default we use a table view but you can change that. If you would prefer that Readerware started up and displayed your items in the thumbnail view, you can do that. Select the view you want to use and then select the View->Save as default view menu item.

You can create multiple views of each type. You could create multiple thumbnail views with different sized thumbnails for example. Where the ability to create multiple views really becomes useful is with table views. You can create multiple table views each with a different set of columns, sorted in a different sequence. You could create a data entry table view that you use after auto-catalog, to clean up the new entries. You could include columns that are typically imported by auto-catalog, and sort the view by Book ID so that the new entries are displayed in the order they were cataloged. You could create a loan view. If you loan items out, you can create a view with loan related columns like borrower, due date etc. You could sort the view by author and title or maybe by borrower. The sort columns are included with each table view you create. So you can switch views to change the columns displayed or just the sequence the items are displayed in.

You can also create table views for reports or exports. If you want to print a report with a given set of columns, create a view containing those columns in the order you want them. Sort the view in the sequence that you want to print the items in. Export too can use a table view to define the columns you want to export. If you regularly export items to import into another program, create a view containing those columns. Then when you run export, select the current view option rather than select the columns individually.

We have mentioned several times that you can sort each table view you create in a different sequence. Another question that comes up a lot is how do you sort a table view? The answer is to click on the column header. An icon is displayed in the header to indicate it is the sort column. The arrow indicates whether the sort is ascending or descending. Click again in the column header to toggle the sequence. To sort on a secondary column hold down the Ctrl key, (Mac users hold down the Apple/Command key), and click on another column header. For example to sort your database by author and title, first click on the author column header. Then hold down the Ctrl key and click on the title column header.

There are multiple ways to change views. You can select from the View->Select view menu item. If you have a lot views and find yourself constantly switching views, you can add the Views list to the toolbar. Select the Preferences menu item, then Toolbars.

The easiest way to create a new view is to copy an existing view and change it to meet your needs. Select the view you want to copy, then select the View->Copy view menu item.

So far all the features we have discussed are available in both Readerware 4 and Readerware 3. As we mentioned at the start of this article, there is a new view related setting available in Readerware 4.17. Users asked for the ability to select a default view for each database. Normally when you switch databases, the new database is displayed using your default view. Now you can define a default view for each database. Maybe you have multiple Readerware databases that you used to catalog different types of items. As you open a book database you want a certain set of columns displayed and sorted by author and title. If you have another database containing maps for example, you might want a different set of columns displayed, this time sorted by just title. Or maybe you want to display your map database in the thumbnail view. Now you can. Select the Preferences menu item, then Database, then Settings. Look for the View Settings section. There is a drop down list containing all your views. If the None option is selected, Readerware works as it does now, when you open another database, it is displayed in the default application view you set. This is the default setting so nothing will change for existing users, everything will work the way it has always done. Select any available view from the drop down list and whenever you open this database, Readerware will display the contents in the selected view.

Views are an integral part of Readerware applications. They control not just how data is displayed on your screen, but how it is printed and exported. A good understanding of views will really help you get the most out of your Readerware applications.

Readerware on macOS Catalina and Windows XP

Readerware on macOS Catalina A followup to the article in the last newsletter about macOS Catalina, 10.15. Talking about macOS Catalina and Windows XP in the same article might seem a little strange, but there is a connection. So this article is not just for Mac users.

The Readerware 4.17 Mac download files have been notarized by Apple. This means that they will run on macOS Catalina as normal.

With the release of macOS Catalina, Apple announced that they were temporarily easing the notarization guidelines until January 2020. Readerware 4.17 is notarized under the relaxed guidelines and we will keep it that way until Apple forces us to use the full notarization process.

The good news is that Readerware can now be fully notarized, we have resolved the issues and all Readerware applications have a clean notarization report. So why didn't we use the new code base for the Readerware 4.17 release? To become fully notarized by Apple took a lot of work and we had to change a number of things below the surface. For example Readerware currently uses Java 8, this is an older version of Java, but one that is still supported and receives regular updates. It has everything we need. To complete the notarization process we had to switch to Java 11, which is very different from Java 8. Many of the components that were standard in Java 8 are no longer included. Some we used, so we had to replace that functionality. We also had to update many of the libraries we use to be compatible with Java 11.

We have of course been testing the new version. However there is still the possibility that problems will surface once the new version is released. There is no real reason for us to upgrade to Java 11 at this point, we would have had to do it at some point, but not yet.

Switching to Java 11 for notarization will force us to drop some platforms. Supporting macOS Catalina will force us to drop earlier versions of macOS. Readerware will now require macOS 10.10, Yosemite, or better.

We will also have to drop support for Windows XP. Although no longer supported by Microsoft, Windows XP is still in use. Another casualty is Linux 32bit support. We are looking at ways where we could continue to support these older operating systems. It might be possible. If you will be impacted by these changes, please let us know so that we can get some idea of the impact these changes will have.

So the possibility of issues with the new code base and incompatibilities with older operating systems mean that we plan to stick with the current code base for as long as possible.

Readerware Client/Server connection recovery

Readerware client/server connections Readerware Client/Server Edition lets multiple computers connect to a central database. In a client/server configuration, the Readerware server opens the database and the Readerware programs are configured to connect to the server, rather than open the database directly.

Readerware establishes the connection to the server at startup, and it must remain connected to the server for the life of the session. If Readerware loses the connection to the server while you are using it, you will typically get an error accessing the database.

 

 

Readerware connection error
Readerware connection error

 


The key in this error dialog is the Connection is broken error message. Readerware had lost the connection to the database and when the user went to update a book, this error occurred.

What happened? All we can say for sure is that Readerware was unable to connect to the database on the server. It could be that the Readerware server or the machine it was running on, had been shutdown. It could also have been a network error of some kind that briefly interrupted the connection to the server database. Because Readerware establishes the connection to the server at startup, once you run into this error, it will keep happening until you reestablish the connection. You can do that in one of two ways, you could restart Readerware or you could go to the File->Open recent menu item and select the first entry, the current database. As long as the Readerware server is running, Readerware will reestablish the connection to the server and you will be able to access the database again.

What if this keeps happening? It probably means there are issues on your network that are triggering these interruptions. You might not notice any problems with other applications on your network. For example your e-mail program, it regularly fetches new mail from your servers, but it does this in separate network sessions. The issue with Readerware is that it needs a continuous network connection. How you run Readerware and your server can have an impact on this.

If you leave Readerware and the Readerware server running all the time, it could be that next morning you will run into this issue. It is best to close Readerware when you are done for a while. Restarting the Readerware server every day will improve database performance and help reduce network connection errors. You should also make sure that the server machine does not go to sleep or enter hibernation.

In Readerware 4.17 we have added an option to automatically reconnect to the Readerware server when problems are detected. This is considered experimental at this time, so it is off by default. To enable this feature, select the Preferences menu item, then Database, then Access. Check the option to Automatically reconnect to server when connection dropped.

The way it works is that when you select a function that requires database access, Readerware checks the database connection, and if there are problems, it will try and automatically reestablish the connection. If after five attempts it is unable to get a connection, it stops trying and the Database Chooser is displayed.

 

 

 

 

Automatically reconnecting to the database
Automatically reconnecting to the database

 


Readerware does not wait for a database connection problem to occur. At that point it is in the middle of a transaction and recovery is not practical. Reestablishing the connection does require that we completely reload the database. Readerware has connections into the database and they must all be refreshed. So we must reconnect to the database and refresh the database contents that are in memory. Then you will need to redo the operation that triggered the reconnect. For example if you click on the Auto-Catalog toolbar button, Readerware first checks to make sure we have a database connection. This is a very quick test so if everything is OK, auto-catalog will launch as normal without any delay. If there is a problem, Readerware will reestablish the connection, this may take a few seconds to refresh the database in memory, so auto-catalog will not start. Once the database connection is back, you can select the auto-catalog button again.

If you try this new feature, we would appreciate your feedback. As we mentioned, the way this feature works is that we check the connection before we access the database. There may be places where this check is missing, if you notice this, please let us know. Also this will not completely eliminate connection errors. If you start a long auto-catalog job for example, we will make sure we have a database connection before auto-catalog starts, but if something goes wrong during a the auto-catalog session, you might still see a connection error.

 

 

Adding your Readerware database to your website

Adding your Readerware database to your website This question comes up quite a bit but it is not something that is included in Readerware, There is no browser access to your Readerware database. It is possible to export your database to HTML and upload static pages to your website, but that is less than ideal.

A Readerware user has started an open source project on GitHub that lets you create an Online Public Access Catalog (OPAC) for your library collection. This project displays your library in a convenient format, you can sort by author or title and you can display images by holding the mouse over the title.

 

 

Readerware library on the web
Readerware library on the web

 


A screenshot helps, but rather than just include a screenshot of how your website database would look, we have used this project to create a small database on the Readerware website. You can access it here. Click on the Title or Author link to sort your database. Hold the mouse over a title to display the cover art.

There are a few prerequisites:

 

 

  • You must have a Readerware Client/Server Edition license in order to create a MySQL version of your database
  • Your website must support MySQL
  • Your website must support PHP

Both MySQL and PHP are common web technologies so chances are your website does provide access to them.

You use Readerware backup and restore to create a MySQL version of your Readerware database on your web server. The restore can restore the database directly to your website. More on using MySQL with Readerware here

Now you need to download the the open source OPAC project from GitHub. There are just a few files to download. Press the 'Download ZIP' button which is located under the "Clone or Download" drop down list. Unzip the files.

You have to edit the Config.php file to enter your database server name, login, database name etc.

Finally upload these files to your website. You should probably install then in a folder. For example we created a library folder on our website and stored the files in there. The link [url=http://www.yourwebsite.com/library]http://www.yourwebsite.com/library[/url] will then display your library collections.

There is a knowledge base article on using the Online Public Access Catalog (OPAC) for Readerware here.

This is a great project which a Readerware user created for their website and then donated to the community so that others can use it and build on it. We hope you will find this project useful and contribute to it, contributing changes back to the project means that all Readerware users can benefit from it.

Readerware Support

Readerware Support There is nothing more important than responding to your questions and feedback. You can always e-mail support@readerware.com and expect a prompt reply. You will receive a reply within 12 hours maximum, normally a lot sooner.

If you have not received a response to your support request within 12 hours, something has gone wrong.

 

  • Check your spam or bulk mail folder, the response may be there.
  • If you are using Microsoft Outlook, check your return address. Microsoft Outlook can send e-mails with an invalid return address that bounces. This has been a real problem lately.
  • Check with your ISP or system administrator, they may have implemented additional spam filters.
  • If you are using a challenge system, please check to see if your response is being held. We do try and respond to challenge e-mails, but it can mean your response is delayed.

If you have not received a response within 12 hours, don't wait any longer, send a follow up e-mail. If possible try and include an alternate e-mail address. We will re-send your answer from another e-mail server to all addresses you supply.

All support e-mail is answered within 12 hours, if you don't get that response, check your anti-spam measures and try again.

 

Subscription information

Subscription information You are receiving this newsletter because you joined the Readerware Newsletter mailing list.

To unsubscribe from this newsletter or change your subscription click here.

You can also unsubscribe from this newsletter by replying to this e-mail with REMOVE in the subject line.


This message was sent by Readerware Corporation.

 

Readerware Corporation
PO Box 1059
Clearlake Oaks CA  95423

 

 

 

Top of Page
Copyright © 2019 Readerware Corporation
Readerware is a registered trademark of The Readerware Corporation.

News

Readerware 4.22 has been released

Readerware 4.22 has been released for Windows, macOS and Linux. Read more...

Read More News

Readerware Newsletter - June 2020

Readerware 4.22 has been released, this is a recommended upgrade for all Readerware 4 users. Plus customizing the detail view Summary tab and new sites. Read more...

Newsletter Archive