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An Introduction to the Readerware Loan Client

The Readerware Loan Client adds circulation support to the Readerware database. You have always been able to check books in and out with the
standard Readerware program and for many the features offered were all they needed. However some users wanted more functionality and a way to
improve the workflow, to make it easier to check books in and out. The Readerware Loan Client addresses both of these issues, It both adds
functionality and makes it easier and faster to check books in and out. 

With the Readerware Loan Client you can:

Add borrowers to the Readerware database and easily maintain the borrower records.
Easily see what books a borrower has on loan.
Import borrowers from external sources.
Delete multiple borrowers in a single transaction.
Print borrower barcodes to speed up the checkout process.
Print borrower reports.
Search for borrowers using virtually any field, ID, last name, phone number, organization etc.
Support for multiple platforms, each component can run on any operating system. You could use Windows to maintain your database

and run the Readerware loan client on a Mac.
Full online help

Learn the basics and get started with the Readerware Loan Client.
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Getting Started with the Readerware Loan Client

When you open the Readerware loan client the main window is displayed. the top section of the window is used to select and maintain borrowers. The
bottom section is used to select the books you want to checkout or return. 

Setting up your default searches

Before you start using the Readerware Loan Client there are some settings you need to decide on:

How do you want to search for borrowers? - You can search for borrowers by ID, name, phone number etc., select the search you want
to use from the drop down list. There is a default search, the one that is selected when you start the program, it is important to make the
search you will use most often the default search. For example if you will be using borrower ID cards with a barcode, you should select
the ID search as the default. This means that the ID search is selected when you start the program and you can simply scan the barcode to
identify the borrower. If you plan on searching on last name, set that as the default search. 

How do you want to search for books? Again you can search on virtually any field but it is important to set the default search. If you will
be searching by ISBN, select the ISBN search, if you will be searching by author, select an author search. If you have assigned your own
barcodes to every book, select a Book ID or User Number search.

To set both the default borrower and book searches, select the Preferences menu item, then Search List. There are separate sections for the borrower
and book searches. You can customize each list, you can show and hide searches, you can move the searches up and down the list. The first search is
the default search, so move the desired search to the top of the list to set the default search. 

Why is this important? Suppose you have set the default borrower search to ID and the default book search to Book ID. Your borrowers have
barcoded ID cards and your books have a barcoded ID label on them. To checkout books you would:

Scan the borrower barcode
Scan the first book barcode
Scan the second book barcode
etc.
Click on the Loan button

That's it, all the selected books are checked out. 

Selecting the mode

The Readerware loan client operates in two modes, loan mode and return mode. It is important to select the mode as this changes the way the program
operates. 

For example in loan mode you have to select the borrower and the books to check out. So when you are in loan mode Readerware sets up the default
searches so that you can quickly do this. 

In return mode things work a little differently. You start off by selecting the borrower as normal but then Readerware displays all the books currently on
loan to this borrower. You can select the books and return them. 

The mode determines how the basic functions within the program work, so it is important to set the mode first. 

By default the Readerware Loan Client opens in loan mode but you can change that in Preferences. 

Using hotkeys

You can assign any function to a hotkey. So for example, rather than click on the Loan button to checkout, you could hit the F2 key. You can set
hotkeys in preferences. Select the Preferences menu item, then Hotkeys.
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Numbering your books

Most libraries will want to track individual copies of books. This lets you keep track of which borrower has which copy. To do this with Readerware
there are two requirements:

Each copy must be entered into the database separately
Each copy must have a unique ID

Adding books to your database

To add each copy to the database separately, simply use auto-catalog as normal and scan the ISBN on each copy. 

There is one change you may have to make first. By default Readerware rejects duplicate ISBNs. You change this setting in preferences. Select the
Preferences menu item, then Database, then Preferences. Make sure that the Allow Duplicate ISBNs option is checked. 

Assigning a unique ID to every copy

As you add each book to the database Readerware assigns it a unique ID, we call this the Book ID. You can add the Book ID column to the table
view and see the ID assigned to each book. 

As you are adding each copy separately, each copy will have a unique ID. 

The ID will be unique and will never change. As you delete books from the database, there will be gaps in the ID. This is normal, a Book ID is never
reused. 

This is the easiest way to assign a unique ID to every book, let Readerware do it for you. You can then print Book ID barcode labels for your books
from within Readerware. 

However there may be times when you want your own IDs. Readerware has a database column for this called User Number. If you prefer you can
enter your own IDs in the User Number column. Again, you can then print User Number barcode labels for your books from within Readerware. 

There are also companies that will print asset tags and asset barcode labels for you. If you prefer to go this route all you need to do is place the
barcode label on the book and then scan it into the Readerware User Number column. 

Checking books out

The fastest way to check a book out is to simply scan the ID barcode on the book, this identifies the particular copy you are checking out. 

If you are using the Book ID column, select a Book ID search and scan your barcode. 

If you have assigned your own numbers, select a User Number search and scan the barcode. 

Remember to setup the default search to whatever ID field you are using.
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The Readerware Loan Client Window

The Readerware Loan Client window consists of four components: 

Menu - The Readerware menu provides access to all functions. 

Toolbar - The toolbar provides quick access to commonly used functions. The toolbar buttons include an icon and label describing the
function. If you need more information on what a button does hold the mouse over it to display a tooltip. The appearance and behavior of
the toolbar can be changed in Preferences. 

Borrower Section - The borrower section is used for selecting and maintaining borrowers. It consists of the borrower search bar that is
used to search for a borrower and a table view where the search results are displayed. You can select a borrower from the table view and
display it in the detail view where you can view and update borrower information. 

Book Section - The book section is used for selecting the books you want to check in or out. It consists of the book search bar that is
used to search for one or more books and a table view where the search results are displayed.
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Readerware Loan Client Menus

The Readerware Loan Client window has the following menus:

File

Select the Open or Open Recent menu items to switch databases. 

Select Properties to display database information and statistics. 

Select from the Print menu to produce various reports:

Borrower report - A report listing the books currently checked out to the selected borrowers. You can
choose to list all borrowers or only borrowers that currently have books checked out. 

Borrower receipt - Print a short receipt for the selected borrowers listing all books they have checked out.
You can then give the receipt to the borrower at checkout or as needed. This is designed for use with receipt
printers but will work on any printer. 

Overdue report - Print a report of all borrowers with overdue books by borrower. The borrower is listed
with contact information followed by their overdue books. 

Borrower ID barcodes - You can print barcode labels containing the borrower ID. These can be used with
ID cards when a borrower checks books in and out. 

Borrower list - Print a simple list of the selected borrowers with their contact information.

Export - Export the selected borrowers to a CSV or TAB delimited file. 

Import - Import a file of borrowers, designed to help you populate your Readerware borrower list from other systems. 

Exit - Close the Readerware Loan Client

Edit

Select Add Borrower to add a new borrower to the database. 

Select Delete Borrowers to delete one or more borrowers from the database. 

Select Loan Mode to switch between loan and return modes. If the menu item is checked, you are in loan mode. 

Depending on the mode of the application this menu item will be displayed as Loan (Check out) or Return (Check in).
Selecting this menu item will perform the specified action. 

When checking books out the Loan Options menu item will be enabled. By default a new loan begins on the current date
and the length of the loan is the value set in preferences. Use this menu item to change the terms on new loans. You can
change the out date and the due date. These settings will be in effect until you change the borrower. i.e. All new loans to this
borrower will use the terms set in the Loan Options dialog. 

When displaying an existing loan the Edit Loan menu item will be enabled. You can edit the terms of the current loan. i.e.
Extend the due date. 

The Clear Outstanding Loans menu item can be used to clear any outstanding loans for the selected books. This function
should be used with caution. It can be used in a classroom situation when you need to clear all outstanding loans at the end of
the school year, it saves you having to return each book individually. It can be used to return a book when it is not possible
to select the borrower first, i.e. when a borrower was deleted with an outstanding loan.

Search
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Select Borrower Search to select the default borrower search. The search bar has the focus and you can enter the search
criteria. 

Select All Borrowers to display all borrowers in the borrower table view. 

Select Book Search to select the default book search. The search bar has the focus and you can enter the search criteria. 

Select All Books to display all books in the book table view.

View

Select Borrower Home to display the current borrower search results in the table view. Designed to be used to return from
the borrower detail view to the borrower table view. 

Select Borrower Detail View to display the currently selected borrower where borrower contact information can be
edited. 

Select Borrower Reload to refresh the current borrower display. 

Select Book Home to display the current book search results in the table view. Designed to be used to return from the book
detail view to the book table view. 

Select Book Detail View to display the currently selected book where the book information can be edited. 

Select Book Reload to refresh the current book display.
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Readerware Loan Client Toolbar

The Readerware Loan Client window toolbar has the following buttons:

Loan/Return Mode - Select this button to Toggle between loan and return modes. The button icon and title will change to indicate the
current mode. 

Loan/Return - Depending on the mode of the application this button will be displayed as Loan (check out) or Return (check in).
Selecting this button will perform the specified action. 

Loan Options - When checking books out the Loan Options button will be enabled. By default a new loan begins on the current date
and the length of the loan is the value set in preferences. Use this button to change the terms on new loans. You can change the out date
and the due date. These settings will be in effect until you change the borrower. i.e. All new loans to this borrower will use the terms set in
the Loan Options dialog. 

Edit Loan - When displaying an existing loan the Edit Loan button will be enabled. You can edit the terms of the current loan. i.e. Extend
the due date. 

Borrower Home - Select Borrower Home to display the current borrower search results in the table view. Designed to be used to
return from the borrower detail view to the borrower table view. 

Add Borrower - Select Add Borrower to add a new borrower to the database. 

Delete Borrowers - Select Delete Borrowers to delete one or more borrowers from the database. 

All Borrowers - Select All Borrowers to display all borrowers in the borrower table view.
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Readerware Loan Client Borrower Section

The borrower section of the Readerware Loan Client window consists of a search bar and table view containing the search results. You can also drill
down and display the detail view for any borrower. 

When the program starts the borrower search bar has the focus, the default search is selected and you are ready to enter the search criteria, scan a
barcode or enter the search text. This means that as soon as the program opens you are ready to search for borrowers. The same thing happens after
you switch between loan and return modes. The idea is that the borrower search bar is the starting point for checking books in and out. 

You can customize the borrower search bar in preferences. It is important to set the appropriate default search. If you are using a barcode reader to
select the borrower, make sure the Borrower ID is the default search selection. If you will be selecting borrowers from the list, make the Borrower
search the default. If you will be searching by last name or phone number, make them the default search. You can always select another search but it is
important that the default search is set so that you are ready to go when the program starts. If you normally check out by barcode then you have the
Borrower ID search as the default. If a borrower has forgotten their ID, you can switch to a last name search for example. 

However you search for borrowers, the matching borrowers are displayed in the table view. That should contain enough information to identify the
correct borrower. You can also click on the green arrow icon to display the borrower in the detail view. If a borrower wants to change their contact
information, you can do this in the borrower detail view. Click on the Borrower Home toolbar button to return to the table view. 

As you select a borrower in the table view, the focus is switched to the book search bar. You are now ready to search for the book to loan out or
return. 

Put this altogether and you can see that the Readerware Loan Client makes it very quick and easy to check books in or out. Scan the borrower
barcode to identify the borrower. Without you doing anything else you are now ready to scan the barcode on the book. Finally click on the Loan button
and the book is checked out. 

You can also assign any function to a hotkey. So rather than click on Loan to checkout, you could hit the F2 key. You can set hotkeys in preferences. 

Changing the loan terms

When you make a new loan, Readerware uses the current date as the loan date and calculates the return date using the default loan period specified in
preferences. If you want to change either date click on the Loan Options toolbar button to display the Loan Options dialog. You can change the loan
out date and the due date. These settings will remain in effect until you change the borrower. i.e. All new loans to this borrower will use the terms set in
the Loan Options dialog. 

Editing a loan

You can also update an existing loan. Switch to return mode, select the borrower and then the book. Click on the Edit Loan toolbar button to display
the Edit Loan dialog. Again you can change both the loan out date and the due date. This is designed to let you extend a loan.
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Readerware Loan Client Book Section

The book section of the Readerware Loan Client window consists of a search bar and table view containing the search results. You can also drill down
and display the detail view for any book. 

When a borrower is selected the focus is transferred to the book search bar. What happens exactly depends on whether the program is in loan mode
or return mode. 

In loan mode the default search is selected and you are already to enter the search criteria, scan a barcode or enter the search text. This means that as
soon as you select the borrower you are ready to select the first book to check out. You can customize the book search bar in preferences. It is
important to set the appropriate default search. If you have assigned your own barcode labels to each book, then you need to select a Book ID or User
Number search. If you will be searching for books using the publisher barcode, you need to select an ISBN search etc. You can always select another
search but it is important that the default search is set so that you are ready to go when a borrower is selected. If you normally check out by ISBN but
you run into a book with no ISBN, you can switch to an author search for example. In loan mode you can search for multiple books and each one will
be added to the results list. When done click on the Loan button to loan out all selected books to the current borrower. 

In return mode Readerware displays the books the borrower has checked out and selects them, you can click on the Return button to check them all in.
To return only some items, change the selection so that only the books to be returned are selected.
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Readerware Table View

The Readerware table view displays your data in a spreadsheet style view.

You can customize the view, you can determine what columns are displayed and in what order. To show or hide a column, right click on a column
header and use the popup menu. To move columns around, drag the column header to the desired location.

Sorting the table view

You can sort the table view on any column(s). To sort on a column, just click on a column header. An icon is displayed in the header to indicate it is the
sort column. The arrow indicates whether the sort is ascending or descending. Click again in the column header to toggle the sequence.

To sort on a secondary column hold down the Ctrl key, (Mac users hold down the Apple/Command key), and click on another column header. For
example to sort your borrowers by last name then first name, first click on the last name column header. Then hold down the Ctrl key and click on the
first name column header.

Navigating the table view

In the book table view most fields are displayed like links in a browser and you can click on them to refine your search results.

For example click on an author to see books by that author. You can keep refining the search results by clicking on links. Use the Book Home menu
item to return to the main result.

You can select one or more rows by clicking on the cursor icon at the beginning of a row.

You can display a particular item in the detail view by clicking on the green enter icon at the beginning of a row. Use the Borrower Home toolbar
button or menu item to return to the table view.

You can jump to a new location in the table view. Right click on a column header, type one or more characters and hit the Enter key. Readerware will
look down the column for the first entry that starts with the specified data and position that row at the top of the view. You can do this with any column
but normally you would choose the primary sort column to jump to a specific borrower for example.
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Readerware Loan Client Detail View

The detail view is used to display the full record and you can add, update and delete records. There is a separate detail view for borrowers and for
books. The book detail view is the same one used in the main product. The borrower detail view is used to maintain your borrowers. As this is the
Readerware Loan Client we will focus on the borrower detail view, you probably won't be updating books in the loan client. If you need to see the
book detail view help page, you will find it here. 

The Readerware borrower detail view is used to:

Add new borrowers to your database. Click on the Add Borrower toolbar button. To add based on an existing borrower, first search for it,
make your changes and click on the Add button.
View borrowers in your database. You can display the detail view from the table view. Click on the green arrow icon on the row you want to
display.
Edit borrowers in your database. You can display the detail view from the table view. All fields are editable, make your changes and click on
the Update button to apply your changes.

To return to the table view, click on the Borrower Home toolbar button. 

At the bottom of the panel is the button bar:

Add - Add a new borrower to the database.
Update - Update a borrower in the database
Delete - Delete a borrower from the database
Clear - Clear all fields
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About your Database

There is only one thing you really need to know about your database, where is it?

The first time you run Readerware you will be prompted to create your database.

The Database Chooser dialog lets you select from the following choices:

Create a New Database - Choose this option if you are a new user. The standard file selection dialog is displayed and you can pick the
location for your new database and enter the database name. The default location for the database is your Documents folder.
Open an Existing Database - Choose this option if you are reinstalling Readerware. The standard file selection dialog is displayed and you can
select your database.
Connect to an External Database - This option is for advanced users and lets you connect to an external database via JDBC.

Readerware remembers the location and will open your database automatically when you start the program. However it is important that you know
where your database is. When you create your initial database take a moment to think about what you want to call it and where you want to create it.
Choose a convenient location that you will remember.

A Readerware database is made up of multiple files and your database is created inside a folder. For example if you create a database called "My
Books", Readerware creates your database in a folder called "My Books.rw3". This keeps all the files together and can make it easier to move or copy
a database.
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View Statistics

You can display the view statistics dialog by selecting the View->Loan Statistics menu item.

It is important to understand that the statistics are for the current book search results. So if you want the statistics for the full database, make sure you
do a full database search or select the Search->All Books menu item. 

This dialog contains the following information about your books: 

Number of titles (records) - This is the number of different titles displayed, i.e. the number of records.

Number of books - This is the number of books displayed. The difference between the title and book counts is that books include
copies. So if you have 2 books displayed and 3 copies of each book, the title count will be 2 and the book count will be 6.

Number of Volumes - This is the number of volumes. i.e. it includes volumes in a multi-volume set.

Number of Active Loans - The number of books that are currently out on loan.

Number of overdue books - The number of books that are currently overdue.

Number of books never checked out - The number of books that have never been checked out. This can be used to determine which
books are unpopular.
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Database Properties

Select the File->Properties menu item to display the Database Properties dialog. 

General Tab

The general tab displays basic information on the current database:

Name - The name of the database main file.For Readerware Server databases this will include the name of the server and the remote file name.
Type - The type of database:

Readerware Local - The is the normal type, it indicates you have opened a database on one of your drives.
Readerware Server - This indicates you are connected to a Readerware server.
External (JDBC) - This indicates you are connected to an external database via JDBC. This could be a MySQl database, Microsoft
SQL server etc.

Location - The location, the path of your database. For Readerware Server databases this will include the name of the server and the path of
the remote database.
Date created - The date the database was created.
Access mode - The current database access mode, Read only, Checkout mode or Full access:

Read only - You can search and browse the database but you cannot make any updates.
Checkout mode - You can search and browse the database, you can check items in and out but you cannot make any other changes to
the database.
Full access - You have full access to the database.

Driver name - The driver used to access the database. For a Readerware local or server database this will be the HSQL Database Engine
Driver, for external databases it will be the driver you chose when configuring the database.
Driver version - The driver version.

Statistics Tab

The statistics tab displays information about our database and the resources used:

Row count - The number of items in your database.
Size (in bytes) - The space your database occupies on disk.
Memory used - The amount of memory currently in use by your database.
Memory allocated - The amount of memory currently allocated by the database engine. Memory is allocated as needed.
Memory free - The amount of memory currently allocated but not in use.
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Using External Databases

Most users will use the built-in database. However advanced users can use other database engines to store their data.

Readerware supports MySQL, SQL Server, PostreSQL and Access, however it should be possible to use any database that includes a JDBC driver.
Contact Readerware support for assistance on getting other databases to work with Readerware.

To access an external database from within Readerware you need to use the advanced open dialog. This is activated in Preferences. 

Connecting to an external database or a Readerware server requires Readerware Client/Server Edition. If the Advanced Open Dialog option is
disabled, you don't have Readerware Client/Server Edition. Upgrades are available on the website. 

Using Readerware with MySQL

You need to install MySQL and create an empty database. Refer to the MySQL documentation for assistance with installation.

You will also need the MySQL JDBC driver, Connector/J. This is available from the MySQL web site, unfortunately licensing restrictions prevent us
from including Connector/J with Readerware.

Opening a MySQL Database

Select the File->Open Database menu item and the Advanced Open Dialog will be displayed.

From the Database type drop down list, choose MySQL. 

The dialog will be filled with appropriate values. There are a couple of entries you will need to customize:

Enter your MySQL user name and password.
In the URL field, change {hostname} to the machine name or IP address where MySQL is running. Use Localhost if it is running on the same
machine.
In the URL field, change {database name} to the name of the MySQL database, you must have already created the empty database in
MySQL.
In Driver Location click on Browse and select the MySQL Connector/J driver

Click on the Test Connection button and Readerware will attempt to connect to the database. If successful click on the OK button to open the
database. If the database is empty Readerware will create the necessary tables. 

Using Readerware with Microsoft SQL Server

You need to install SQL Server and create an empty database. Refer to the SQL Server documentation for assistance with installation.

You will also need the Microsoft SQL Server JDBC driver installed.

Opening a SQL Server Database
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Select the File->Open Database menu item and the Advanced Open Dialog will be displayed.

From the Database type drop down list, choose SQL Server. 

The dialog will be filled with appropriate values. There are a couple of entries you will need to customize:

Enter your SQL Server user name and password.
In the URL field, change {hostname} to the machine name or IP address where SQL Server is running. Use Localhost if it is running on the
same machine.
In the URL field, change {instance name} to the name of the SQL Server instance you are connecting to.
In the URL field, change {database name} to the name of the SQL Server database, you must have already created the empty database in
SQL Server.
In Driver Location click on Browse and select the Microsoft SQL Server JDBC driver

Click on the Test Connection button and Readerware will attempt to connect to the database. If successful click on the OK button to open the
database. If the database is empty Readerware will create the necessary tables. 

If you get a connection error check to make sure that SQL Server has been set up to accept TCP/IP connections. Use the SQL Server Configuration
Manager and select Network Configuration. Now select Protocols for the SQL Server instance you are connecting to. Make sure TCP/IP support is
enabled as shown in the screen below. 

 

You also need to set the correct TCP/IP port for IPAll. Right click on TCP/IP and select Properties from the popup menu. Select the IP Addresses
tab. Locate IPAll and set it to use port 1433 or whatever port you are using. 
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Using Readerware with PostgreSQL

You need to install PostgreSQL and create an empty database. Refer to the PostgreSQL documentation for assistance with installation.

You will also need the PostgreSQL JDBC driver. This is available from the PostgreSQL web site, unfortunately licensing restrictions prevent us from
including it with Readerware. 

Opening a PostgreSQL Database

Select the File->Open Database menu item and the Advanced Open Dialog will be displayed.

From the Database type drop down list, choose PostgreSQL. 

The dialog will be filled with appropriate values. There are a couple of entries you will need to customize:

Enter your PostgreSQL user name and password.
In the URL field, change {hostname} to the machine name or IP address where PostgreSQL is running. Use Localhost if it is running on the
same machine.
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In the URL field, change {database name} to the name of the PostgreSQL database, you must have already created the empty database in
PostgreSQL.
In Driver Location click on Browse and select the PostgreSQL driver

Click on the Test Connection button and Readerware will attempt to connect to the database. If successful click on the OK button to open the
database. If the database is empty Readerware will create the necessary tables. 

Using Readerware with Access

Access 2007 and earlier only provide 32 bit drivers. If you are running Readerware on a 64 bit system, you must install the 32 bit version of
Readerware so that it can talk to Access. 

Access 2010 does include both 32 and 64 bit versions. You must install the matching version of Readerware. If you install the 32 bit version of Access,
you must install the 32 bit version of Readerware. If you install the 64 bit version of Access, you must install the 64 bit version of Readerware. 

You need to install Access and create an empty database. Refer to the Access documentation for assistance with installation.

Opening an Access Database

Select the File->Open Database menu item and the Advanced Open Dialog will be displayed.

From the Database type drop down list, choose Access. 

The dialog will be filled with appropriate values. There are a couple of entries you will need to customize:

Enter your Access user name and password, if needed
In the URL field, change {Access file} to the full path of the Access database.

For example:

jdbc:odbc:Driver={Microsoft Access Driver (*.mdb,
*.accdb)};DBQ=C:\Access.accdb;DriverID=22;READONLY=false}

Click on the Test Connection button and Readerware will attempt to connect to the database. If successful click on the OK button to open the
database. If the database is empty Readerware will create the necessary tables.

Access Connection Errors

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified - This error indicates that Windows can not
find the Access driver, you are probably using an older version of Access. Click on the Windows start menu and enter ODBC in the search or run field.
Windows will open the ODBC Data Source Administrator control panel. Look for the Microsoft Access entry and make a note of whatever is listed in
the Driver field. Back in Readerware replace Microsoft Access Driver (*.mdb, *.accdb). in the URL field with whatever is listed in the Driver field
in the ODBC window. 

Page 21 of 54



[Microsoft][ODBC Microsoft Access Driver] General error Unable to open registry key ... - This Access error can occur if the Access
database name is incorrect. Check for syntax errors and to make sure the Access database exists. 

Changing Databases

If you want to change database engines and move an existing database to a new format, use backup and restore.

Backup your existing database and then run the restore selecting the backup file you just created. On the Database Selection page of the wizard, click
on the Browse button and select the new database as normal.

For example you could backup a standard Readerware database and restore it to a MySQL database. Once the restore completes Readerware will
open your new database and your existing data will be displayed. 

Important note: You must restore the backup to an empty database. Do not open the external database in Readerware first as that will create the
standard database tables and the restore will fail. Create an empty database and then restore a Readerware backup to it.
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Readerware Loan Client Export Wizard

The Readerware Loan Client export allows you to export the borrowers in your Readerware database to a  number of different formats:

CSV, (Comma Separated Value) - This is a standard data interchange format, use it to transfer data to other programs and databases.
TAB Delimited - Another standard data interchange format. You can open a TAB delimited in file in a spreadsheet program like Microsoft
Excel. A TAB delimited file provides an easy way to transfer your borrowers to an Excel spreadsheet.

Exporting

These are the basic steps:

1. Pick the format you want to export to
2. Select the file you want to export to
3. Run Readerware export
4. Check the results

Format Selection

This is the first page of the Readerware export wizard. The first step is to select  which format you want to create the file in. Your choices are:

CSV, (Comma Separated Value)
TAB delimited.

CSV/TAB Delimited Options

When you select the CSV or TAB delimited formats the following options are available:

Output header line - Include the column header line used to identify the columns contained in the file.
Enclose fields in double quotes - Readerware will enclose fields in double quotes when necessary. Use this option when you always need the
fields enclosed in double quotes.
Escape new lines - Some other programs cannot import fields containing new lines. Choose this option and Readerware will replace new lines
with '\n'.

File Selection

You need to tell Readerware the destination for the exported data. 

Click on the Browse button and select the file from the standard selection dialog.

If you check the Always replace existing file check box Readerware will automatically overwrite this file if it exists. This is useful if you are doing
regular export runs to the same file. If this is not checked, Readerware will display a confirmation dialog before overwriting an existing file. 

For TAB delimited and CSV files you can also select the file encoding. This is important if your database contains data in multiple languages. You are
exporting data from Readerware and importing into another program. It is important that you select the encoding that the other program is expecting. If
there is a mismatch then data may not transfer correctly.

ANSI - This is your system encoding and is the default. It will work for databases that contain the system language.
Unicode (little endian) - Unicode is a double byte character set and can handle virtually any language and any combination of languages.
Little endian is used on Intel systems.
Unicode (big endian) - Unicode is a double byte character set and can handle virtually any language and any combination of languages.
Big endian is used on other systems like PPC.
UTF-8 - UTF-8 is a variable width encoding and can handle all characters in the Unicode character set. It has become popular as you
don't need to worry about endianness.

Page 23 of 54



In general you should choose either ANSI or UTF-8. If you are exporting your database to another program on the same system ANSI should work
fine. If your database contains multiple languages or you are transferring the file to another computer, use UTF-8. But remember the other program
must be able to handle the encoding you select, so check their documentation. 

Verification Page

Next up is the verification page. This is your last chance to change your settings prior to running Readerware export. A quick summary of your choices
is listed. Click on Next if you are ready to go. Click on Back if you want to change your choices. 

Export Running Page

When you reach this page, Readerware export is running. You will see a progress bar that will update as Readerware exports the data to the file.
Immediately below the progress bar is a Cancel button which you can use to interrupt the export.

When the export completes, click on the Next button to proceed to the final page of this wizard. 

Export Complete Page

This page displays the overall export statistics:

Borrowers Processed - The number of borrowers written to the export file
Errors - The number of borrowers that could not be written.

When you are done, click the Finish  button to exit the export wizard.
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Readerware Loan Client Import Wizard

The Readerware Loan Client can import borrower information from other databases and programs. 

Readerware can import:

CSV or Comma Separated Value files - These files contain the data for each database column separated by a comma. The first line of
the file is a mapping line which allows you to map the data to Readerware database column names. 

TAB Delimited Files - These are similar to CSV files except that the data is separated by the tab character. Again the first line of the file
is a mapping line which allows you to map the data to Readerware database column names.

Mapping data for import into Readerware

A CSV or TAB delimited file is organized much like a spreadsheet. Each record in the file is a row in the spreadsheet. Each record contains the data
for each column in that row. 

Here is an example of a CSV file:

"BRWR_FNAME","BRWR_LNAME","BRWR_ID" 
"John","Doe","10023"

The problem is how does Readerware know what order the columns are in? The mapping line is key to importing data into Readerware. The first row
of the file is the mapping line and it identifies which Readerware database columns the data should be imported into. This is a common technique used
with CSV and TAB delimited files, your file may already have a mapping line as the first line of the file. or it may just contain the data. You need to
open the file using a text editor like Notepad or TextEdit. Look at the first line. If there is a mapping line, you need to change the column names to
match the Readerware column names. If it is not there, you need to add the line. 

If there are columns in the file you do not want to import into Readerware you can use a column name of "Junk". Any column name that Readerware
does not recognize will be skipped. 

Readerware Column Names

Use the following table to build the mapping line.

Readerware Column Names
Column Name Contents

BRWR_FNAME Borrower first name
BRWR_LNAME Borrower last name
BRWR_ID Borrower ID
BRWR_STATUS Borrower status, Active, Inactive or Banned
BRWR_EMAIL E-Mail address
BRWR_PHONE1 Phone number
BRWR_PHONE2 Phone number
BRWR_FAX Fax number
BRWR_ORG Organization
BRWR_ADDR1 Address line 1
BRWR_ADDR2 Address line 2
BRWR_CITY City
BRWR_STATE State, province, territory etc.
BRWR_ZIP Zip or postal code
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Importing

These are the basic steps:

1. Indicate the format of the file you are going to import
2. Select the file
3. Run the Readerware import
4. Check the results

Format Selection

This is the first page of the Readerware import wizard. The first step is to select which format the file you are importing is in. Your choices are CSV,
(Comma Separated Value) or TAB delimited. See above for more information on the file formats. 

Duplicate Handling

By default Readerware adds all the borrowers in the imported file to the database. You can select to replace duplicate borrowers rather than add them.

Readerware uses the Borrower ID field to detect duplicates. If the replace option is checked and the borrower ID already exists in the database, the
borrower record is replaced with the imported data. 

File Selection

You need to tell Readerware the name of the file you wish to import and where it is located. Click on the Browse button and select the file using the
standard file selection dialog. 

For TAB delimited and CSV files you can also select the file encoding. You are importing data from another program into Readerware. It is important
that Readerware uses the correct encoding when reading the file. If there is a mismatch then data may not transfer correctly.

Automatic detection - In most cases Readerware can determine the encoding by examining the file. This is the default selection and you
should normally use this and only specify an explicit encoding if there is a problem.
ANSI - This is your system encoding and is the default. It will work for databases that contain the system language.
Unicode (little endian) - Unicode is a double byte character set and can handle virtually any language and any combination of languages.
Little endian is used on Intel systems.
Unicode (big endian) - Unicode is a double byte character set and can handle virtually any language and any combination of languages.
Big endian is used on other systems like PPC.
UTF-8 - UTF-8 is a variable width encoding and can handle all characters in the Unicode character set. It has become popular as you
don't need to worry about endianness.

In general you should use automatic detection. If Readerware is unable to determine the encoding used, you can select the correct encoding from the
list. 

Verification Page

Next up is the verification page. This is your last chance to change your settings prior to running Readerware import. A quick summary of your choices
is listed. Click on Next> if you are ready to go. Click on Back if you want to change your choices. 

Import Running Page

When you reach this page, your Readerware import is running. You will see a progress bar that will update as Readerware imports the data from the
file. 

Page 26 of 54



When the import completes, click on the Next button to proceed to the final page of this wizard. 

Import Completed Page

This page displays the overall import statistics:

Borrowers Processed - The number of borrowers in the imported file
Errors - The number of borrowers that could not be imported.

When you are done, click the Finish button to exit the import wizard.
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Printing a Borrower Report

Readerware lets you print a borrower report that lists all books a borrower has checked out along with the due date and contact information. 

Selecting the borrowers to print

Readerware will print a report for the current search results, selected borrowers or borrowers with active loans. Start by searching your database to list
the borrowers you want to print. Now select File->Print->Borrower report. 

Printing Reports

Select and setup your printer 

Select the items you want to print - You can print the current search results or selected borrowers or active borrowers, i.e. borrowers with current
loans outstanding. 

Setup the page - You can choose the font, orientation and margins for the report. 

Click on the Print button to print your borrower report.
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Printing a Borrower Receipt

Readerware lets you print a borrower receipt that lists all books a borrower has checked out and also identifies overdue books. 

The borrower receipt is designed to work with receipt printers and generate a compact listing that you can slip inside a book at checkout. You can
configure the Readerware Loan Client so that it automatically prints the receipt at checkout, select the Preferences menu item, then Loans. 

If you prefer you can only print the receipt on request or to help with a user query. Select the File->Print->Borrower receipt menu item. 

Selecting the borrowers to print

Readerware will print a receipt for the currently selected borrowers. Start by searching your database to list the borrowers you want to print. Now
select File->Print->Borrower receipt. 

Printing Receipts

Select and setup your printer 

Setup the page - You can choose the font and margins for the receipt. 

Optional message - You can optionally include a few lines of text to be displayed at the bottom of each receipt. You could include the name of your
library, maybe a website or phone number etc. 

Click on the Print button to print your borrower receipt.
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Printing an Overdue Report

Readerware lets you print a list of overdue books organized by borrower. It will include the borrower contact information and a list of their overdue
books. 

Printing Reports

Select and setup your printer 

Setup the page - You can choose the font, orientation and margins for the report. 

Click on the Print button to print your overdue report.
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Printing Barcodes

Readerware lets you print borrower ID barcodes from your database. Use borrower ID barcodes to identify your borrowers as they check books in
and out. 

Selecting the borrowers to print

Readerware will print ID barcodes for the current search results or selected borrowers. Start by searching your database to list the borrowers you want
to print. Now select File->Print->Borrower ID barcodes. 

Printing Barcodes

Select and setup your printer - You can print barcodes on any ink jet or laser printer using label sheets. Readerware also supports Dymo
LabelWriter label printers which take label rolls. 

Select the items you want to print - You can print the current search results or selected items. 

Choose your label stock from the list - Readerware supports Avery 5160/8160 label sheets on any ink jet or laser printer. If you have a Dymo
LabelWriter printer select either the 30252 address labels or 1738595 barcode labels. The address labels normally work best, they are easier to find in
stores and are bigger. They can hold both the barcode and additional text. The Dymo barcode labels are smaller and have room for a barcode only. 

Add a line of text to your label - You can optionally include the borrower name that will be output below the barcode. 

Click on the Print button to print your barcode labels.
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Printing a Borrower List

Readerware lets you print a list of your borrowers. This is a simple spreadsheet like report of the borrowers and borrower columns displayed on your
screen. 

You can select your printer, the page setup and appearance for the report. 

Click on the Print button to print your borrower list.
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General Preferences

Readerware General Preferences are used to configure basic options such as the user interface, startup, logging etc. 

Look and Feel Preferences

Readerware supports multiple "look and feel" implementations. The choices available will depend on the platform you are using, Windows, Macintosh
etc. The look and feel determines how components such as buttons and list boxes etc. look and behave. It also controls how a component reacts to
mouse and keyboard input. 

If the Show tooltips option is checked, Readerware will display tooltips for buttons etc. 

If the Include images on menus option is checked, Readerware will include icons for many menu bar items. 

Browser Preferences

The browser preferences determine how Readerware launches your browser. 

Readerware will normally find your default browser automatically. If the Let Readerware find your browser automatically option is turned on,
Readerware will then determine the location of your browser from the operating system. If for some reason this does not work or if you have multiple
browsers installed and want Readerware to use a specific browser, clear this option and select the browser 

Media Player Preferences

The media player preferences determine how Readerware launches your media player. 

Readerware will normally find your default media player automatically. If the Let Readerware find your media player automatically option is
turned on, Readerware will then determine the location of your media player from the operating system. If for some reason this does not work or if you
have multiple media players installed and want Readerware to use a specific program, clear this option and select the media player. 

Logging Preferences

The logging options determine when Readerware will create log files. 

When the Enable user logging option is checked, operations such as auto-catalog, import etc. will produce a log file. Click on the View Log button
when the operation completes to see the log. 

When the Enable Readerware logging option is checked, Readerware will create a full session log to assist in problem resolution. This should only
be turned on at the request of Readerware Support as it can impact performance. 

Startup Preferences

These options control what operations Readerware performs as it starts. 

If the Show tip of the day option is checked, Readerware will display a tip window with help on commonly used features of the program. A different
tip is displayed each time you start Readerware. You can page through the tips and close the window when you are done. After you have become
familiar with Readerware, you can turn this option off. 

If the Show splash screen option is checked, Readerware will display a progress window as it starts. 

If the Start in Edit Mode option is checked, Readerware will start the program in edit mode, i.e. you can edit cells in the table view. If not checked
Readerware is started in navigation mode and you can click on links to refine the search results. 

If the Start in Return Mode option is checked in the Readerware Loan Client, it will start the program in return mode, If not checked the Readerware
Loan Client is started in loan mode. 
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Exit Preferences

There preferences control which operations Readerware performs at exit. 

When Readerware is run for the first time, it displays the main window in a default position and at a size that will fit on a basic screen. You can resize
and move the window to meet your needs. 

When the Remember size & position option is set, Readerware will remember the size and position of each window when you close the application
and restore them next time you start the application. There are two basic ways to use this feature:

You can leave Remember size & position on and always have your windows open at the location you left them when you last closed
Readerware.
Establish a new default position and size and select the Edit->Save Window Positions menu item and turn this option off. Readerware will then
open windows at your default location and size rather than the last used location and size.

When the Prompt for backup if database changed option is set, Readerware will display a backup reminder dialog whenever you close the program
after making changes to the database. If you close Readerware without making any database changes, Readerware closes as normal. The backup
reminder dialog will give you a chance to backup your Readerware database and safeguard your data. If you turn this option off, remember to backup
your database regularly by selecting the File->Backup Database menu item.
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Toolbar Preferences

Use this panel to change how toolbars are displayed.

Display options

You can choose to display toolbars with icons and labels, icons only or labels only. 

The default is to display both icons and labels. Once you are familiar with the toolbar you can turn off the labels to reduce the size and clutter.

Button tooltips

If checked Readerware will display a popup window when you hold the mouse over a toolbar button. If clear no tooltips are displayed.

The tooltip will display a more detailed description of what the button does. A good combination is to turn off labels and turn on tooltips. You have a
smaller toolbar and can display the tooltip if you ever forget what a button does.

Icon sizes

You can display the toolbar icons in the following sizes: 

Small 24 pixels
Medium  32 pixels
Large 48 pixels
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Update Preferences

Readerware can check for product updates at regular intervals. Using this preferences panel you can turn the update check on and off, set the interval
and manually check for updates.

Check for updates automatically

If checked Readerware will check for updates at the specified interval. If cleared Readerware will never check for updates.

If update checking is turned on you can set the interval in days. If you set the interval to seven days, Readerware will next check for updates in seven
days time and every seven days after that.

We do recommend that you check for updates regularly.

Check Now

You can check for updates at any time by clicking on the Check Now button.

If a new version is available Readerware will display the latest version number and enable the Go to Download Page button. This will launch your
browser and take you to the Readerware web site where you can download the latest version.
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Table View Preferences

This panel is used to change table view preferences. 

Display Preferences

Use system row background color

If checked Readerware will query the operating system for the table row background color. If cleared Readerware will use a white row background. 

Alternate row background color

Readerware can display alternate row background colors, i.e. even numbered rows in one color, odd numbered rows in another color. If checked
Readerware will display alternating row background colors If cleared Readerware will display all rows with the standard background color. 

This option is on by default on Mac OS X, it is off by default on all other platforms. 

Display single result in detail view

When a search returns a single result you have the option of displaying this item in the table view as a single row or in the detail view, just as if you had
selected the detail view from the table. 

If checked Readerware will display a single result in the detail view. If cleared Readerware will display it in the table view. 

Highlight links in table

When in navigation mode Readerware can highlight links in the table similar to a browser. In Readerware you can click on a link to refine the search
results, i.e. click on an author link to display all books by that author. 

If checked Readerware will highlight links. If cleared Readerware will not highlight links but the mouse pointer will still change as it goes over a link and
the link will still function. 

Sort Preferences

Case sensitive

Readerware searches are normally case insensitive. An example of a case insensitive sort is:

Smith, jane 
Smith, John 
Smith, joseph

If you check the Case sensitive box, the same search results would be displayed in the following sequence:

Smith, John 
Smith, jane 
Smith, joseph

Ignore initial articles

If the Ignore initial articles box is checked Readerware will ignore articles of speech at the start of a field, (A, An and The). For example:

A Murder in Mayfair
The Murder Room
Murder Scholastic
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A Murder Too Many

If the Ignore initial articles box is cleared, the same titles will be sorted in the following sequence:

A Murder in Mayfair
A Murder Too Many
Murder Scholastic
The Murder Room

Readerware can also switch the titles for you. If you prefer to format the title as Murder Room, The use the Readerware Bulk Editor to reformat the
title.

Strict alphabetical title sort

If the Strict alphabetical title sort box is checked, articles of speech found anywhere in the title field are ignored, (A, An and The). Spacing and
punctuation are ignored, the title is sorted in strict letter by letter sequence. For example:

The Harder They Come
Hard Feelings

All spacing is eliminated and e comes before f so the titles will be listed in the above order.

If the Strict alphabetical title sort box is cleared, the titles would be listed in the following sequence:

Hard Feelings
The Harder They Come

This assumes that the Ignore initial articles box is checked. 

This option is only used when sorting by title.
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Search List Preferences

The Readerware Loan Client includes two search bars, a borrower search bar and a book search bar. 

You can customize both search bars. You can show and hide items and change the order. Hide the searches you never user, move the searches you
use all the time to the top of the list. 

The first item in each search bar is the default search. You should set the default search to match how you normally search for items. For example, if
you normally search for borrowers by scanning a barcode, you should set the default search to Borrower ID, i.e. put the Borrower ID search at the top
of the list.

Search List

Searches displayed with a green check mark are included in the search bar, those displayed with a red X are hidden. Double-click on an entry to toggle
its state.

To change the order of a search entry in the list select it and use the arrow keys to move it up or down.
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Database Preferences

Use this panel to change Readerware database options, these control how Readerware stores and displays your data.

Run Default Search on Open

If checked Readerware will run the default search whenever you start the program or open a new database.

With this option on you will see the results of your default search when you start Readerware. With it off you will see a blank page. Turning this option
off can improve startup time.

Include Image Support

If checked Readerware will automatically add images for each item you catalog using auto-catalog or drag & drop. You will be able to manually add
images for other books.

Images can take up a lot of space, so if you do not need them you can clear this option and no images will be stored.

Include Want List in Searches

If checked Readerware will include your want list in database searches. If not checked, want list items are excluded from database searches. An item is
determined to be in your want list if the status is Want or Ordered. 

Note: This applies to all database searches except when you are searching by Status. If you search the database for items with a status of Want or
Ordered, they will always be returned regardless of how this option is set.

Refresh History

If checked Readerware will automatically reload result pages that have changed when they are accessed using the navigation buttons, Home, Back,
Forward. If unchecked, the page is displayed as is. This may mean that the page does not reflect the current database state. It is normally OK to leave
this option checked but if reloading a page from history becomes too slow because the database has grown very large, you can turn this option off.

Allow Duplicate ISBNs/UPCs

If checked Readerware will allow duplicate primary keys in the database, the ISBN of a book, the UPC of an album or video. If not checked,
Readerware will reject duplicates. 

Date Preferences

Readerware can display dates in one of three formats, the full date, month and year or year only. Sometimes you don't have the full date, you might
know the exact date you purchased an item but might only know the year an item was released. 

Select the date you want to change from the list and then set the appropriate option.
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Database Access Preferences

Use this panel to specify how the database should be accessed, set a password etc.

Database Open Dialog

If the Standard Open Dialog option is selected Readerware uses the standard operating system file selection dialog and you can open your local
database.

If the Advanced Open Dialog is selected Readerware will use a custom dialog that will let you open a standard database, connect to an external
database or connect to a Readerware Server. 

Connecting to an external database or a Readerware server requires Readerware Client/Server Edition. If the Advanced Open Dialog option is
disabled, you don't have Readerware Client/Server Edition. Upgrades are available on the website.

Database Access Mode

The database access mode is the mode Readerware will use when a database is opened. Choose from:

Full Access - You have full access to the database
Checkout Mode Access - You can check items in and out but no other updates are permitted
Read Only Access - You can search and browse the database, no updates are permitted

You can optionally disable access to preferences in read only or checkout modes.

Require a password for full access

If the database access mode has been set to read only or checkout mode, you can request full access to the database later using the Edit->Request
Update Access menu item.

If the require password option has been set, you will have to enter the password before full access will be granted.

You can use this option to restrict full access to authorized users. For example if you set the mode to checkout, users will be able to search, browse
and checkout items. If you are an authorized user you can request full access, supply the password and you will be able to update the database.

The next time Readerware is started the access mode is set to checkout mode again.

If a password has been set, you will need to provide the existing password before you can change these settings.

Open recent menu item count

The File->Open recent menu item can be used to switch between databases. By default it holds the last six accessed databases. You can change this
to a value between 2 and 25.
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User Defined Column Preferences

The Readerware User Columns Preferences tab is used to define additional columns in the Readerware database. These can be used for whatever
information you want.

Once activated the columns can be added to the table view, and will be automatically displayed in the detail view. You can also perform searches on
user defined columns.

To activate a column, check the Active check box.

Enter the Column Title, this value will be displayed as the column header in the table view, as the tag name in the detail view, and as the search choice
in the search bar.

Select the column type:

Test Field - This is a single line text field that can contain any alphanumeric data
Whole Number Field - This is a single line field that can only contain whole numbers. The contents of this field will be displayed right aligned.
When sorting on this column, Readerware performs a numeric sort.
Yes/No (Checkbox) field - A boolean field that can contain a Yes or No value. This field behaves like all Readerware boolean fields. In the
table view it displays as Yes or No, in edit mode you can change the value by selecting from a list. In the detail view this field is displayed as a
checkbox.

When adding a new field you can use the Bulk Editor to set an appropriate default value. For example when defining a new whole number field you
might want to set a default value of 0.

To remove a column, clear the Active checkbox. Note that this does not remove the column or the data entered from the database, it simply removes it
from display. 
 

The Button Panel

Once you have made your changes, click on OK to save them and have them take effect. Click on Cancel to discard your changes.
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Proxy Preferences

The Readerware Proxy Preferences tab is used when you access the internet through a proxy server. You specify the name and port of the proxy
server. See your system administrator if you need help with proxy settings.

HTTP Host - Enter the name of the proxy server host used for normal HTTP access.

HTTP Port - Enter the port number of the proxy server host used for normal HTTP access.

Security Host - Enter the name of the proxy server host used for secure HTTPS access.

Security Port - Enter the port number of the proxy server host used for secure HTTPS access. 
 

The Button Panel

Once you have made your changes, click on OK to save them and have them take effect. Click on Cancel to discard your changes. Note you only
have to click on OK when you have finished all your changes, you can move between tabs and only click OK when you are done. This will close the
Readerware preferences dialog.
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Book Preferences

The Readerware Book Preferences tab is used to configure book related settings. 
 

ISBN Handling

By default Readerware validates each ISBN you enter. If you receive an error when entering an ISBN, it means that the ISBN check digit validation
failed. Normally you can resolve this by checking the ISBN and correcting it. Occasionally you might find that Readerware rejects an ISBN even
though you entered it exactly as printed on the book. Very rarely the publisher may include an invalid ISBN, this is normally on older titles, issued when
the ISBN was new.

You can tell Readerware to accept the invalid ISBN anyway using the error dialog that is displayed.

If you want to disable ISBN validation and accept whatever you enter without requiring you to respond to the confirmation dialog, check the Accept
Invalid ISBN  Without Confirmation radio button. Clear this button and Readerware will display a confirmation dialog whenever it encounters an
invalid ISBN. 
  

UPC Manufacturer Mapping

To convert a mass market paperback UPC or barcode to an ISBN, Readerware needs to map the UPC manufacturer code to the ISBN publisher
code. Using this table, you can delete and change the mappings. Normally this is handled automatically when you scan the barcode, but you can change
the mappings and add codes for publishers that have been assigned multiple codes. More info.

The Button Panel

Once you have made your changes, click on OK to save them and have them take effect. Click on Cancel to discard your changes. Note you only
have to click on OK when you have finished all your changes, you can move between tabs and only click OK when you are done. This will close the
Readerware preferences dialog.
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Loan Preferences

Use this panel to maintain loan related preferences. 

Loan Defaults

Default Loan Period (in days) - When you check out a book, the loan tracker sets the default return date. This is specified as the number of days,
the default is 7 days. 

Print receipts at checkout - When this option is checked the Readerware Loan Client will automatically print out a receipt when you check books
out. The borrower receipt is designed to be used with receipt printers and will produce a compact receipt that you can slip into a book at checkout. If
this option is off Readerware will not automatically print a receipt but you can always print one on request by selecting the File->Print->Borrower
receipt menu item. 

Before turning on the automatic receipt option, you should manually print some receipts to set up the print options. 

Loan Search Mode

When you check books out to a borrower, you can check them out one at a time or batch all books and check out once per borrower. 

When batch mode is off, every time you search for a book it replaces the current search results and you can check each book out separately. 

When the batch mode option is checked, every time you search for a book it is added to the search results. When all books are displayed you can
complete the loan and all books will be checked out. 

Loan Statistics

Readerware can optionally track the number of times an item has been loaned out and the last loan date. 

This information can help you decide which items are popular and which can be removed from your library. 

If you do not need to track loan statistics, you can turn this option off. 

Database Searches

Normally Readerware displays loan information only when you use a Loan search. Loan searches return loans, other searches return items. For
example suppose you have 5 copies of a book with 3 copies on loan. If you search for books on loan, Readerware will return this book 3 times with
the appropriate loan information for each copy. A normal search will just return the item once so it is not possible to report accurate loan information. 

There are times though when it is useful to have basic loan information when running a normal search. You can request that Readerware always include
loan information by checking the Always return loan information checkbox. Readerware will now include information from the first loan in all
searches. 

If you have entered each copy of an item separately in the database, this will enable you to determine at a glance which titles are available and which are
out. If you have entered multiple copies into the database once and set the copies count, then you will need to drill down into any item that is out on
loan to determine whether or not copies are still available. Select the Edit->Check In/Out menu item. 

Dialog preferences

Readerware can display a confirmation dialog whenever a book is loaned out or returned or when a borrower is added or updated. You can turn these
dialogs on or off. 
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The Readerware Command Line

When specifying Readerware command line options you must follow the program name with the options. For example:

C:\Program Files\Readerware 3\readerware.exe <options>

Windows has a lot of problems if there are spaces in any value. You must put the value in double quotes. If both the program name and the option have
spaces, you must put each in a separate set of double quotes. For example:

"C:\Program Files\Readerware 3\readerware.exe" -db"C:\Library\My Books.rw3\My Books.rw3.data"

If you put the whole line in one set of double quotes, Windows will not parse the command line correctly.

Readerware Options

Readerware will accept the following options on the command line: 
 

Database Name

You can use the -db option to include the full path name of a Readerware database on the command line.

-db"C:\Users\Bill\Documents\Readerware\My Books.rw3\My Books.rw3.data"

Debug Mode

You can use the -debug option to start Readerware in debug mode. You should only use this option at the direction of Readerware technical support.
It can impact system performance.:

-debug
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Readerware Client/Server Edition

Readerware Client/Server edition is designed to allow multiple users to connect to a central database. It can be used on home networks to manage
personal collections. It can also be used in libraries, churches, schools and enterprise locations to catalog and manage a library. 

The Readerware server can run on any platform. It does not need a dedicated server, it will run in the background on any machine, you can even run
both client and server on the same machine. 

You can have any mix of clients, Windows, Mac and Linux users can all access the same Readerware server. 

You can publish your database in read only, checkout or update mode. Selected users can be given update access. So for example you could publish
your database in checkout mode so that all users can browse the database and check items out. Selected users can be given update access so that they
can add new items and maintain the database. 

Installing the Readerware Server

The Readerware Server is included in all distributions. Installation is a little different on each platform but you just need to make sure that the
Readerware server component is selected during the installation process. 

Before you start the server you must setup your Readerware database(s) on the server machine. 

If this is a new installation you can create a new empty database using the normal Readerware program, select File->New Database. 

If you have an existing database you can use backup & restore to transfer it to the server machine. 

Running the server as a Windows service

On Windows the Readerware Server is run as a Windows service, you must first install it. Start the RWServer Config utility using the Windows Start
menu. On Windows 7 and Windows Vista, the Readerware Server Configuration Utility requires administrator rights so Windows UAC might prompt
you to approve the program before it is launched. Select the Service->Install RWServer Service menu item, this will install the Readerware server
as a Windows service that will be started automatically every time you start your computer. You can also use the Service menu to check the status of
the server, stop and start the server etc. 

Once installed, another way to stop and start the server is by using the Windows Services Control Panel. The Windows Services Control Panel can
also be used to change the server properties. Locate RWServer in the list and double click on it to open the properties dialog. There are a couple of
settings you might want to change: 

Startup type - The default setting is Automatic, Windows will start the Readerware Server as Windows starts. You can change this to
Automatic (Delayed Start). Windows will still start the Readerware Server automatically but not until Windows is fully launched. Choose
this option if you need to have other processes start before the Readerware Server. For example you might have your Readerware
database on an encrypted disk. If started right away the disk may not be available. Using the delayed start option gives you a chance to
load the encrypted disk first. 

Log on as - By default the Readerware server runs as a local system account. This normally works fine unless you have your database
stored in a folder owned by a particular user. In this case the system account may be denied access to the database. You can fix this by
providing the appropriate log on credentials and Windows will start the Readerware Server under that account.

Running the server on Mac OS X

The RWServer and RWServer Config applications are included in a separate Mac OS X distribution and should be installed into your Applications
folder. 

The RWServer application does not open a window but runs in the background. 

You can shut down the server from the RWServer Config Utility. 
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Running the server on Linux

You can start the Readerware Server from the desktop by selecting Applications->Office->RWServer. 

A startup script is also provided which you can use to launch the server: 

rwserver.sh

You will find the script the Readerware installation folder. 

You can shut down the server from the RWServer Config Utility. 

Configuring the Readerware Server

You configure the Readerware server using the configuration utility. You run this on the server machine. 

Note: Mac users need administrator rights when running the configuration utility. You will receive an error when saving the configuration if
you do not have administrator rights. 

Port configuration

The Readerware Server uses two TCP/IP ports for database communications, and one TCP/IP port for mobile communications.. 

The control port is used by both the configuration utility and the Readerware client to communicate with the Readerware server. The default control
port is 9010 

The data port is used to send data between the client and server. The Readerware server only has one data port which is used by all databases. The
default data port in 9001. 

The mobile port is used to sync your databases to a mobile device. The default data port in 9002. 

You should use the default ports unless there is a port conflict with another application. 

If you are using firewall software you must ensure that all three ports are open. 

Database configuration

Each database is configured separately, click on the appropriate tab. i.e. Server (Books). 

You need to provide the location of the database which can be done by clicking on the Browse button. 

The access mode must be set to one of the following:

Read only - All users can view the database but cannot make any changes to the database, this includes checking out an item. 

Checkout mode - All users can view the database and check books in and out. No other updates are permitted. 

Full Access - All users have full access to the database.

The update password is used in read only and checkout modes. The Readerware client allows users to request update access. The user must provide
this password to get full access to the database. 

If you have purchased Readerware you must supply your registration name and code to register the server program. If running in evaluation mode,
leave these fields blank. 

Use the Save Server Configuration button to save your changes. 
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To test the server you can click on the Restart Server button. You should ensure that no clients are accessing the server before you restart it. 

To shutdown the Readerware server select the File->Shutdown Server menu item. You should ensure that no clients are accessing the server before it
is shut down. This will do a controlled shutdown of the server and terminate the task. If you need to restart the server after a shutdown, you have to do
this from the operating system. 

Configuring the Readerware Client

To use Readerware in client/server mode you must select the advanced open dialog option. Select the Preferences menu item, then Database, then
Access. 

Now when you open a Readerware database, select File->Open Database, you will see the advanced open dialog. Select the option to connect to a
Readerware Server and enter the server name or IP address and the control port. The control port must be the same as the control port set in the
server configuration utility. 

Readerware will connect to the server and display your database as normal. Readerware remembers the last accessed database and will open it
automatically the next time the program is started. So normally you set up Readerware to connect to the server once and Readerware connects to your
server each time the program is started. 

Readerware Server Log File

The Readerware server logs basic activity and errors to a log file. The file is called rwserver.log and it will be created in your Documents folder,
Readerware->Logs. 

If you experience any problems, the answer can normally be found in the log file. This is a plain text file and can be viewed in any text editor. 

Connection problems

If the client cannot connect to the Readerware server it is normally one of the following issues: 

The Readerware server is not running or does not have the appropriate database open. Check the rwServer.LOG file on the server machine
to verify that the Readerware server has started normally and that the database is open. If you start the server and open a Readerware and
ReaderwareAW database but do not open a ReaderwareVW database, then you will receive an error if you try to connect from a ReaderwareVW
client. 

The operating system cannot resolve the server name. The first thing to check is that the two machines can communicate. From the remote
machine, open a command prompt and enter the following command:

ping servername

where servername is the name of the machine running the Readerware server. If the ping works, then we know the two machines can communicate. If
not there is some sort of networking problem between the two machines. Try using the machine IP address in place of the server name. Readerware
will accept either. 

Your Firewall is blocking the server ports. If the ping works but Readerware is still unable to connect, then it is probably your firewall software
blocking the ports Readerware is using. 

It is often easier to get started by running the server and client on the same machine. That takes things like firewalls out of the picture. Once you get it
running on the same machine, you know the server is configured correctly and you can then try connecting from another machine. 

Database Maintenance

You should perform periodic maintenance on your Readerware server databases. 

As you add new items to your server databases, the database will grow in size and should be compacted for better performance and to reduce disk
space usage. As your databases stabilize and you are no longer adding a lot of new items, the need to compact the database will be reduced. 
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Use the RWServer Config utility to compact your databases, select from the Database menu. Depending on the size of your database, it may take a
while to compact a database. The server will be placed in maintenance mode while the database is compacted. No new connections will be accepted
until the operation completes. You can not interrupt the process while the database is being compacted, it must be allowed to complete. 

It is a good idea to backup your database before compacting it. 

The Compact Database Wizard will guide you through the process. The first screen displays the full path of the database and the current database size.
Verify that you are compacting the correct database and click Next to start compacting. 

When the operation completes the Next button will be enabled. Click Next to display the results screen. RWServer Config will display the original size
of the database and the new compacted size. This should give a good idea of how often your databases needs to be compacted. 

Readerware Mobile Database Synchronization

If you are using mobile devices you can configure the Readerware Server to allow mobile devices to copy the databases from the server. 

The default port for Readerware Mobile sync is 9002. It is recommended that you use the default port unless there are port conflicts with other
applications. Click on the Ports tab to change the mobile sync port. 

Each database is configured separately, click on the appropriate tab. i.e. Mobile (Books). Check the mobile sync option and optionally define the fields
and lengths that you want to transfer to your mobile devices. 

When done save the configuration and restart the server. You can now sync your mobile devices by connecting to the Readerware Server using the IP
address displayed and port 9002.
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Remote Database Connection Dialog

This dialog is displayed when you select File->Open Database from the Readerware menu and you have selected the remote database option. 
 

Instructions

To connect to a Readerware server you need to enter two pieces of information:

The name of the machine the server is running on. If you are running the client and server on the same machine, you can enter
'Localhost'. Otherwise you should enter the name or IP address of the machine on which the Readerware server is running. For Example:

Localhost

or

MyServer

or

192.168.0.1

The location of the remote database images. This would normally be on a network drive that you have mapped to the Readerware
server machine. 
 

The Button Panel

Once you have entered the information, click on OK to connect to the Readerware server. Click on Cancel to abort the operation.
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RWServer Properties File

The easiest way to configure the Readerware server is to use the RWServer Configuration Utility. This will create the rwserver.properties file for you in
the correct location. You can also configure the server by creating your own rwserver.properties file using a text editor. 

Creating the Server Configuration File

The configuration file specifies the databases and modes etc. This file must be called "rwserver.properties". 

There are four sections to the configuration file. A common section where server properties are specified and three product sections where you specify
the product and database information. 

The common section can contain the following entries:

rw.svr.cp={Control port, default 9010}
rw.svr.dp={Data port, default 9001}

The product sections can contain the following entries:

rw.svr.ena={Database enabled (true or false)}
rw.svr.rnme={Registration name}
rw.svr.rcde={Registration code}
rw.svr.db={full path to the database}
rw.svr.mde={Database mode: 0=full, 1=checkout, 2=read only}

The above examples are configuring Readerware for books. To configure the music version start they keys with aw, i.e. aw.svr.db. For the video
version the keys start with vw. 

You do not need to start all databases, if you are only running Readerware for books, then you only need to define the rw.svr entries. 

Note that special characters must be escaped with the backslash character. So to enter a backslash you must enter \\. 

Example:

rw.svr.cp=9010
rw.svr.dp=9001

rw.svr.ena=true
rw.svr.rnme=Readerware User
rw.svr.rcde=RW-XXXX-XXXX-XXXX-XXXX
rw.svr.db=D\:\\ReaderwareDB\\Books.rw3\\Books.rw3.data
rw.svr.mde=0

Saving the Server Configuration File

The configuration file must be called "rwserver.properties". The location is determined by the operating system. 

On Windows the configuration file must be stored in the location pointed to by the ALLUSERSPROFILE environment variable. Create a Readerware
folder at that location and store the file in there. For example:

C:\ProgramData\Readerware\rwserver.properties

On Mac OS X the configuration file must be stored in the Application Support folder. Create a Readerware folder at that location and store the file in
there. For example:

/Library/Application Support/Readerware/rwserver.properties

On Linux the configuration file must be stored in your home folder. There should be a .readerware3 folder in there. For example:
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/home/me/.readerware3/rwserver.properties

You can use an alternate location by editing the rwserver.sh script and adding the parameter "-Duser.home=/your/location" after the java
command. For Example:

java -Duser.home=/your/location ...

Readerware will then look for the following file:

/your/location/.readerware3/rwserver.properties
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